import Foundation
let pattern = #"^(?:\d{2}-\d{2}(?:;|$))+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"10-02;34-05;12-12;23-05;10-42;44-05"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}