import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4})-(\\d{2})-(\\d{2})(.*)";
final String string = "2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49";
final String subst = "\\1/\\2/\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}