// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{4})-(\d{2})-(\d{2})(.*)").unwrap();
let string = "2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49";
let substitution = "\\1/\\2/\\3\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}