using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*src=""(.*)""";
string input = @"<div class=""row"">
<!-- 注意里面三个 img 标签是在同一行 -->
<img src=""https://static.fastadmin.net/assets/images/app/code.png"" alt=""> <img src=""https://static.fastadmin.net/assets/images/app/browser.png"" alt=""> <img src=""https://static.fastadmin.net/assets/images/app/laptop.png"" alt="">
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}