package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.*src="(.*)"`)
var str = `<div class="row">
<!-- 注意里面三个 img 标签是在同一行 -->
<img src="https://static.fastadmin.net/assets/images/app/code.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/browser.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/laptop.png" alt="">
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}