# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\*.*?\*\///gs;t' <<< " abc def /* h*i */
abc /* hi */ def /* h*i */
abc def "