using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\*.*?\*/";
string substitution = @"";
string input = @" abc def /* h*i */
abc /* hi */ def /* h*i */
abc def ";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}