use strict;
my $str = ' abc def /* h*i */
abc /* hi */ def /* h*i */
abc def ';
my $regex = qr~/\*.*?\*/~sp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";