$re = '~/\*.*?\*/~s';
$str = ' abc def /* h*i */
abc /* hi */ def /* h*i */
abc def ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;