package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((\+|-)((0[0-9])|(1[0-2])):([0-5][0-9]))|([A-Za-z]+\/[A-Za-z]+))$`)
var str = `Austalia/Sydney`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}