const regex = /^(((\+|-)((0[0-9])|(1[0-2])):([0-5][0-9]))|([A-Za-z]+\/[A-Za-z]+))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\+|-)((0[0-9])|(1[0-2])):([0-5][0-9]))|([A-Za-z]+\\\/[A-Za-z]+))$', '')
const str = `Austalia/Sydney`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}