re = /^(((\+|-)((0[0-9])|(1[0-2])):([0-5][0-9]))|([A-Za-z]+\/[A-Za-z]+))$/
str = 'Austalia/Sydney'
# Print the match result
str.match(re) do |match|
puts match.to_s
end