using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-z]+(\s|\s?[:\/]\s?)\d+";
string input = @"Name 1234567
Name : 123
Name: 123
Name/1234567";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}