package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-z]+(\s|\s?[:\/]\s?)\d+`)
var str = `Name 1234567
Name : 123
Name: 123
Name/1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}