$re = '/[a-zA-z]+(\s|\s?[:\/]\s?)\d+/';
$str = 'Name 1234567
Name : 123
Name: 123
Name/1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);