re = /[a-zA-z]+(\s|\s?[:\/]\s?)\d+/
str = 'Name 1234567
Name : 123
Name: 123
Name/1234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end