#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>"
Local $sString = "<input type="text" value="<? print(variable); ?>">" & @CRLF & _
"" & @CRLF & _
"<? /*<br><br><small>Data:</small>" & @CRLF & _
"" & @CRLF & _
"<input type="text" value="<? print(data); ?>"> */ ?>" & @CRLF & _
"" & @CRLF & _
"<textarea><? print(yuppy); ?></textarea>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")