$re = '/<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>/';
$str = '<input type="text" value="<? print(variable); ?>">
<? /*<br><br><small>Data:</small>
<input type="text" value="<? print(data); ?>"> */ ?>
<textarea><? print(yuppy); ?></textarea>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);