import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?\\s*((?:.*\\/\\*[\\s\\S]+\\*\\/.*)|(?:[\\s\\S]+?))\\s*\\?>";
final String string = "<input type=\"text\" value=\"<? print(variable); ?>\">\n\n"
+ "<? /*<br><br><small>Data:</small>\n\n"
+ "<input type=\"text\" value=\"<? print(data); ?>\"> */ ?>\n\n"
+ "<textarea><? print(yuppy); ?></textarea>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}