using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?\s*((?:.*\/\*[\s\S]+\*\/.*)|(?:[\s\S]+?))\s*\?>";
string input = @"<input type=""text"" value=""<? print(variable); ?>"">
<? /*<br><br><small>Data:</small>
<input type=""text"" value=""<? print(data); ?>""> */ ?>
<textarea><? print(yuppy); ?></textarea>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}