using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/fhir/(dstu[1-9])/([^/?]+)(/?.*)";
string input = @"/fhir/dstu1/Resource?query";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}