const regex = new RegExp('/fhir/(dstu[1-9])/([^/?]+)(/?.*)', '')
const str = `/fhir/dstu1/Resource?query`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}