$re = '`/fhir/(dstu[1-9])/([^/?]+)(/?.*)`';
$str = '/fhir/dstu1/Resource?query';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);