package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/fhir/(dstu[1-9])/([^/?]+)(/?.*)`)
var str = `/fhir/dstu1/Resource?query`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}