using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\([^\\]+)\\([^\\]+)\\$";
string input = @"C:\input\rsgc\statements_and_inserts\Australia\";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}