re = /\\([^\\]+)\\([^\\]+)\\$/
str = 'C:\\input\\rsgc\\statements_and_inserts\\Australia\\'
# Print the match result
str.match(re) do |match|
puts match.to_s
end