$re = '/\\\\([^\\\\]+)\\\\([^\\\\]+)\\\\$/';
$str = 'C:\\input\\rsgc\\statements_and_inserts\\Australia\\';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);