package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\([^\\]+)\\([^\\]+)\\$`)
var str = `C:\input\rsgc\statements_and_inserts\Australia\`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}