# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\S+\^(\d+)(?=\^)/\1/;t' <<< "abc^28092015^def^1234."