const regex = /^\S+\^(\d+)(?=\^)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\S+\\^(\\d+)(?=\\^)', '')
const str = `abc^28092015^def^1234.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);