use strict;
my $str = 'abc^28092015^def^1234.';
my $regex = qr/^\S+\^(\d+)(?=\^)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";