#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\-]*\-){7}(?<your_field>\d+)"
Local $sString = "bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447" & @CRLF & _
"bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672" & @CRLF & _
"bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")