const regex = /^([^\-]*\-){7}(?<your_field>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\-]*\\-){7}(?<your_field>\\d+)', 'gm')
const str = `bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}