$re = '/^([^\-]*\-){7}(?<your_field>\d+)/m';
$str = 'bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);