import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RIJDEN\\?\\s*(.+?)(?:\\R+\\d|\\R*$)";
final String string = "testtestest\n\n"
+ "1. QUESTION QUESTION RIJDEN?\n"
+ "Txt pour regex1 \n"
+ " \n"
+ "2. QUESTION QUESTION BESTUURDER Txt p0ur regex2,\n\n"
+ " \n"
+ "3. QUESTION QUESTION /POSTCODE)\n"
+ "Txt pour regex3;rz\n"
+ " \n"
+ "Fin";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}