using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z][a-z]*[ ]?)*,?[ ](?:LLC|Inc|Corporation|Corp|Co)";
string input = @"""John works at Uber Technologies, Inc as a senior software engineer while Amanda works at Google LLC as a product manager""
Uber, Inc
Uber Technologies, Inc.
Google LLC
Fiserv Corporation
Fiserv Corp.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}