$re = '/(?:[A-Z][a-z]*[ ]?)*,?[ ](?:LLC|Inc|Corporation|Corp|Co)/m';
$str = '"John works at Uber Technologies, Inc as a senior software engineer while Amanda works at Google LLC as a product manager"
Uber, Inc
Uber Technologies, Inc.
Google LLC
Fiserv Corporation
Fiserv Corp.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);