const regex = /(?:[A-Z][a-z]*[ ]?)*,?[ ](?:LLC|Inc|Corporation|Corp|Co)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[A-Z][a-z]*[ ]?)*,?[ ](?:LLC|Inc|Corporation|Corp|Co)', 'gm')
const str = `"John works at Uber Technologies, Inc as a senior software engineer while Amanda works at Google LLC as a product manager"
Uber, Inc
Uber Technologies, Inc.
Google LLC
Fiserv Corporation
Fiserv Corp.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}