import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Z][a-z]*[ ]?)*,?[ ](?:LLC|Inc|Corporation|Corp|Co)";
final String string = "\"John works at Uber Technologies, Inc as a senior software engineer while Amanda works at Google LLC as a product manager\"\n\n"
+ "Uber, Inc\n"
+ "Uber Technologies, Inc.\n"
+ "Google LLC\n"
+ "Fiserv Corporation\n"
+ "Fiserv Corp.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}