$re = '/this\.dialogs = {.*};/s';
$str = ' this.dialogs = {
errorDialogComponent: ko.observable(),
searchIndividualsDialogComponent: ko.observable(),
searchAccountsDialogComponent: ko.observable(),
addBlocksDialogComponent: ko.observable(),
deleteBlocksDialogComponent: ko.observable(),
folioGroupDialogComponent: ko.observable(),
groupServicesOverviewDialogComponent: ko.observable(),
roomingListDialogComponent: ko.observable()
};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);