#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)<([^\/> ]+?)\s*?([^>]*)\s*(?:\/>|>(.*)<\/\1>)"
Local $sString = " <?xml version="1.0"?>" & @CRLF & _
" <Name attribute = "value" attribute2="value2" >Convert number to string</Name>" & @CRLF & _
" <CommandLine>Examp1.EXE</CommandLine>" & @CRLF & _
" <Input>1</Input>" & @CRLF & _
" <Output>One</Output>" & @CRLF & _
" <Test TestId="0002" TestType="CMD">" & @CRLF & _
" <Name>Find succeeding characters</Name>" & @CRLF & _
" <CommandLine>Examp2.EXE</CommandLine>" & @CRLF & _
" <Input>abc</Input>" & @CRLF & _
" <Output>def</Output>" & @CRLF & _
" </Test>" & @CRLF & _
" <Test TestId="0003" TestType="GUI">" & @CRLF & _
" <Name>Convert multiple numbers to strings</Name>" & @CRLF & _
" <CommandLine>Examp2.EXE /Verbose</CommandLine>" & @CRLF & _
" <Input>123</Input>" & @CRLF & _
" <Output>One Two Three</Output>" & @CRLF & _
" </Test>" & @CRLF & _
" <Test TestId="0004" TestType="GUI">" & @CRLF & _
" <Name>Find correlated key</Name>" & @CRLF & _
" <CommandLine>Examp3.EXE</CommandLine>" & @CRLF & _
" <Input>a1</Input>" & @CRLF & _
" <Output>b1</Output>" & @CRLF & _
" </Test>" & @CRLF & _
" <Test TestId="0005" TestType="GUI">" & @CRLF & _
" <Name>Count characters</Name>" & @CRLF & _
" <CommandLine>FinalExamp.EXE</CommandLine>" & @CRLF & _
" <Input>This is a test</Input>" & @CRLF & _
" <Output>14</Output>" & @CRLF & _
" </Test>" & @CRLF & _
" <Test TestId="0006" TestType="GUI">" & @CRLF & _
" <Name>Another Test</Name>" & @CRLF & _
" <CommandLine>Examp2.EXE</CommandLine>" & @CRLF & _
" <Input>Test Input</Input>" & @CRLF & _
" <Output>10</Output>" & @CRLF & _
" </Test>" & @CRLF & _
" <Test/>" & @CRLF & _
" <Test />" & @CRLF & _
" <Test></Test>" & @CRLF & _
" <Test attribute = "value" attribute2="value2"/>" & @CRLF & _
" <Test attribute = "value" attribute2="value2" />" & @CRLF & _
" <Test attribute = "value" attribute2="value2" ></Test>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<([^\/> ]+?)\s*?([^>]*)\s*(?:\/>|>(.*)<\/\1>) - (with g-, s- & U-modifiers) finds all tags in scope" & @CRLF & _
"" & @CRLF & _
"1st group is tagname" & @CRLF & _
"2nd group is attributes" & @CRLF & _
"3rd group (if it exists) is value of the tag" & @CRLF & _
"" & @CRLF & _
"Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Apply pattern below on 2nd group to find all attributes:" & @CRLF & _
"" & @CRLF & _
"\s*([^<>\=" ]+)\s*=\s*"([^"]*)" - (with g-modifier) finds attributes" & @CRLF & _
"" & @CRLF & _
" 1st group is attributename" & @CRLF & _
" 2nd group is attributevalue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")