# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([^\/> ]+?)\s*?([^>]*)\s*(?:\/>|>(.*)<\/\1>)"
test_str = (" <?xml version=\"1.0\"?>\n"
" <Name attribute = \"value\" attribute2=\"value2\" >Convert number to string</Name>\n"
" <CommandLine>Examp1.EXE</CommandLine>\n"
" <Input>1</Input>\n"
" <Output>One</Output>\n"
" <Test TestId=\"0002\" TestType=\"CMD\">\n"
" <Name>Find succeeding characters</Name>\n"
" <CommandLine>Examp2.EXE</CommandLine>\n"
" <Input>abc</Input>\n"
" <Output>def</Output>\n"
" </Test>\n"
" <Test TestId=\"0003\" TestType=\"GUI\">\n"
" <Name>Convert multiple numbers to strings</Name>\n"
" <CommandLine>Examp2.EXE /Verbose</CommandLine>\n"
" <Input>123</Input>\n"
" <Output>One Two Three</Output>\n"
" </Test>\n"
" <Test TestId=\"0004\" TestType=\"GUI\">\n"
" <Name>Find correlated key</Name>\n"
" <CommandLine>Examp3.EXE</CommandLine>\n"
" <Input>a1</Input>\n"
" <Output>b1</Output>\n"
" </Test>\n"
" <Test TestId=\"0005\" TestType=\"GUI\">\n"
" <Name>Count characters</Name>\n"
" <CommandLine>FinalExamp.EXE</CommandLine>\n"
" <Input>This is a test</Input>\n"
" <Output>14</Output>\n"
" </Test>\n"
" <Test TestId=\"0006\" TestType=\"GUI\">\n"
" <Name>Another Test</Name>\n"
" <CommandLine>Examp2.EXE</CommandLine>\n"
" <Input>Test Input</Input>\n"
" <Output>10</Output>\n"
" </Test>\n"
" <Test/>\n"
" <Test />\n"
" <Test></Test>\n"
" <Test attribute = \"value\" attribute2=\"value2\"/>\n"
" <Test attribute = \"value\" attribute2=\"value2\" />\n"
" <Test attribute = \"value\" attribute2=\"value2\" ></Test>\n\n\n\n"
"<([^\\/> ]+?)\\s*?([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) - (with g-, s- & U-modifiers) finds all tags in scope\n\n"
"1st group is tagname\n"
"2nd group is attributes\n"
"3rd group (if it exists) is value of the tag\n\n"
"Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)\n\n\n"
"Apply pattern below on 2nd group to find all attributes:\n\n"
"\\s*([^<>\\=\" ]+)\\s*=\\s*\"([^\"]*)\" - (with g-modifier) finds attributes\n\n"
" 1st group is attributename\n"
" 2nd group is attributevalue")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.