$re = '/<([^\/> ]+?)\s*?([^>]*)\s*(?:\/>|>(.*)<\/\1>)/sU';
$str = ' <?xml version="1.0"?>
<Name attribute = "value" attribute2="value2" >Convert number to string</Name>
<CommandLine>Examp1.EXE</CommandLine>
<Input>1</Input>
<Output>One</Output>
<Test TestId="0002" TestType="CMD">
<Name>Find succeeding characters</Name>
<CommandLine>Examp2.EXE</CommandLine>
<Input>abc</Input>
<Output>def</Output>
</Test>
<Test TestId="0003" TestType="GUI">
<Name>Convert multiple numbers to strings</Name>
<CommandLine>Examp2.EXE /Verbose</CommandLine>
<Input>123</Input>
<Output>One Two Three</Output>
</Test>
<Test TestId="0004" TestType="GUI">
<Name>Find correlated key</Name>
<CommandLine>Examp3.EXE</CommandLine>
<Input>a1</Input>
<Output>b1</Output>
</Test>
<Test TestId="0005" TestType="GUI">
<Name>Count characters</Name>
<CommandLine>FinalExamp.EXE</CommandLine>
<Input>This is a test</Input>
<Output>14</Output>
</Test>
<Test TestId="0006" TestType="GUI">
<Name>Another Test</Name>
<CommandLine>Examp2.EXE</CommandLine>
<Input>Test Input</Input>
<Output>10</Output>
</Test>
<Test/>
<Test />
<Test></Test>
<Test attribute = "value" attribute2="value2"/>
<Test attribute = "value" attribute2="value2" />
<Test attribute = "value" attribute2="value2" ></Test>
<([^\\/> ]+?)\\s*?([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) - (with g-, s- & U-modifiers) finds all tags in scope
1st group is tagname
2nd group is attributes
3rd group (if it exists) is value of the tag
Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)
Apply pattern below on 2nd group to find all attributes:
\\s*([^<>\\=" ]+)\\s*=\\s*"([^"]*)" - (with g-modifier) finds attributes
1st group is attributename
2nd group is attributevalue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);