import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^\\/> ]+?)\\s*?([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>)";
final String string = " <?xml version=\"1.0\"?>\n"
+ " <Name attribute = \"value\" attribute2=\"value2\" >Convert number to string</Name>\n"
+ " <CommandLine>Examp1.EXE</CommandLine>\n"
+ " <Input>1</Input>\n"
+ " <Output>One</Output>\n"
+ " <Test TestId=\"0002\" TestType=\"CMD\">\n"
+ " <Name>Find succeeding characters</Name>\n"
+ " <CommandLine>Examp2.EXE</CommandLine>\n"
+ " <Input>abc</Input>\n"
+ " <Output>def</Output>\n"
+ " </Test>\n"
+ " <Test TestId=\"0003\" TestType=\"GUI\">\n"
+ " <Name>Convert multiple numbers to strings</Name>\n"
+ " <CommandLine>Examp2.EXE /Verbose</CommandLine>\n"
+ " <Input>123</Input>\n"
+ " <Output>One Two Three</Output>\n"
+ " </Test>\n"
+ " <Test TestId=\"0004\" TestType=\"GUI\">\n"
+ " <Name>Find correlated key</Name>\n"
+ " <CommandLine>Examp3.EXE</CommandLine>\n"
+ " <Input>a1</Input>\n"
+ " <Output>b1</Output>\n"
+ " </Test>\n"
+ " <Test TestId=\"0005\" TestType=\"GUI\">\n"
+ " <Name>Count characters</Name>\n"
+ " <CommandLine>FinalExamp.EXE</CommandLine>\n"
+ " <Input>This is a test</Input>\n"
+ " <Output>14</Output>\n"
+ " </Test>\n"
+ " <Test TestId=\"0006\" TestType=\"GUI\">\n"
+ " <Name>Another Test</Name>\n"
+ " <CommandLine>Examp2.EXE</CommandLine>\n"
+ " <Input>Test Input</Input>\n"
+ " <Output>10</Output>\n"
+ " </Test>\n"
+ " <Test/>\n"
+ " <Test />\n"
+ " <Test></Test>\n"
+ " <Test attribute = \"value\" attribute2=\"value2\"/>\n"
+ " <Test attribute = \"value\" attribute2=\"value2\" />\n"
+ " <Test attribute = \"value\" attribute2=\"value2\" ></Test>\n\n\n\n"
+ "<([^\\/> ]+?)\\s*?([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) - (with g-, s- & U-modifiers) finds all tags in scope\n\n"
+ "1st group is tagname\n"
+ "2nd group is attributes\n"
+ "3rd group (if it exists) is value of the tag\n\n"
+ "Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)\n\n\n"
+ "Apply pattern below on 2nd group to find all attributes:\n\n"
+ "\\s*([^<>\\=\" ]+)\\s*=\\s*\"([^\"]*)\" - (with g-modifier) finds attributes\n\n"
+ " 1st group is attributename\n"
+ " 2nd group is attributevalue";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}