using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\?)page_no=\d+&|&page_no=\d+\b";
string substitution = @"";
string input = @"http://exanmple.com/katalogas/?page_no=12&is_search=1&type=list&page_no=22&filter=search_1&activity=&activity_id=&activity=langai&activity_id=®ion_id=-2&page_no=2";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}