use strict;
my $str = 'http://exanmple.com/katalogas/?page_no=12&is_search=1&type=list&page_no=22&filter=search_1&activity=&activity_id=&activity=langai&activity_id=®ion_id=-2&page_no=2';
my $regex = qr/(?<=\?)page_no=\d+&|&page_no=\d+\b/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";