$re = '/(?<=\?)page_no=\d+&|&page_no=\d+\b/i';
$str = 'http://exanmple.com/katalogas/?page_no=12&is_search=1&type=list&page_no=22&filter=search_1&activity=&activity_id=&activity=langai&activity_id=®ion_id=-2&page_no=2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;