import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\?)page_no=\\d+&|&page_no=\\d+\\b";
final String string = "http://exanmple.com/katalogas/?page_no=12&is_search=1&type=list&page_no=22&filter=search_1&activity=&activity_id=&activity=langai&activity_id=®ion_id=-2&page_no=2";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}