#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((?!.*(anime|manga|hentai|sex|xxx)).*)$"
Local $sString = "This sentence contains anime" & @CRLF & _
"dsakdask Manga sakdklsa" & @CRLF & _
"sadlksadlk Hentai sklsdakl" & @CRLF & _
"Lots and lots of sex stuff" & @CRLF & _
"This sentence should pass" & @CRLF & _
"xxx movies sdkjsadk" & @CRLF & _
"hello world. this also should pass"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")