re = /^((?!.*(anime|manga|hentai|sex|xxx)).*)$/mi
str = 'This sentence contains anime
dsakdask Manga sakdklsa
sadlksadlk Hentai sklsdakl
Lots and lots of sex stuff
This sentence should pass
xxx movies sdkjsadk
hello world. this also should pass'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end